SuperWebSocket useless because Browsers need to open custom ports?

Aug 1, 2012 at 6:33 PM
Edited Aug 1, 2012 at 6:35 PM

Hi!

I'am developing a project using SuperWebSocket. 

I am hosting SuperWebSocket within ASP.NET application on IIS7.5. The clients of this WebSocket server are browsers (IE10, Firefox, Chrome). 

The problem is that SuperWebSocket cannot be initialized on port 80 because it's used by IIS.

So when I start WebSocket server on custom port, browsers with Windows Firewall enabled won't work properly.

Is there any workaround for this? Or do I need to wait for IIS8?

Thanks in advance!

Coordinator
Aug 2, 2012 at 1:43 AM

I think you can use another host name for your SuperWebSocket.

* bind a new internal IP for this server

* let SuperWebSocket instance listen on this new internal IP

* resolve the host name to the new inertnal IP

 

 

Aug 2, 2012 at 3:08 PM

kerryjlang,

Thanks for the response.

I understand your solution, but I need to host the websocket server in same WebApplication as the root WebApp.

Seems to be inexplicable, but that's what I need. In this case I assume I need to wait for IIS8.

Thanks again!