Can't Host in IIS

Feb 13, 2013 at 1:11 PM
Hi Kerry,

Thank you for your hard work in this project. I have one simple question, why I can't host it in my hosting IIS. the IIS is IIS 7, I even try to host the sample project with webchat interface it is not working.

It always say: *connecting to server... then *connection closed.

Could you please give me some hint why this is happening?

Thanks
Feb 15, 2013 at 10:53 AM
Did you check the logs? The logs must have some information.

Sent from my Windows Phone

From: ocky_saktya
Sent: 2/13/2013 9:11 PM
To: kerry-jiang@hotmail.com
Subject: Can't Host in IIS [SuperWebSocket:432957]

From: ocky_saktya

Hi Kerry,

Thank you for your hard work in this project. I have one simple question, why I can't host it in my hosting IIS. the IIS is IIS 7, I even try to host the sample project with webchat interface it is not working.

It always say: *connecting to server... then *connection closed.

Could you please give me some hint why this is happening?

Thanks
Feb 17, 2013 at 8:51 AM
Hi Kerry,

Thanks for your respond. Which log that you talking about? I have the log4net config in my working directory but can't find the err.log or info.log, I only can find the system.net.trace.log. The only suspicious information in that log is this:

System.Net.Sockets Error: 0 : [3704] Exception in the Socket#43749873::IOControl - The system detected an invalid pointer address in attempting to use a pointer argument in a call

and the IIS hosting is working at my local, but not at my hosting environment. I have tried to make the config and permission similar but no use.

Thanks in advance for your time and hard work, Kerry.
Feb 17, 2013 at 9:44 AM
The log4net.config should be put under the directory "\Config".

Sent from my Windows Phone

From: ocky_saktya
Sent: 2/17/2013 4:51 PM
To: kerry-jiang@hotmail.com
Subject: Re: Can't Host in IIS [SuperWebSocket:432957]

From: ocky_saktya

Hi Kerry,

Thanks for your respond. Which log that you talking about? I have the log4net config in my working directory but can't find the err.log or info.log, I only can find the system.net.trace.log. The only suspicious information in that log is this:

System.Net.Sockets Error: 0 : [3704] Exception in the Socket#43749873::IOControl - The system detected an invalid pointer address in attempting to use a pointer argument in a call

and the IIS hosting is working at my local, but not at my hosting environment. I have tried to make the config and permission similar but no use.

Thanks in advance for your time and hard work, Kerry.