Missing AppServerBase.cs

Apr 13, 2013 at 6:31 PM
I'm playing around a little bit with the SuperWebSocket. I created a C# 4.0 Console application. I then ran the build.bat file found in the source code and added all the files in the bin folder as a reference to my console app, along with the files in the reference folder.

I added the following code to a class:

        private WebSocketServer socketServer;

        public void start() {
            socketServer = new WebSocketServer();

            if (!socketServer.Setup(8711)) {
                // Problem setting up the server

            socketServer.NewMessageReceived += socketServer_NewMessageReceived;
            socketServer.NewSessionConnected += socketServer_NewSessionConnected;
            if (!socketServer.Start()) {
                // Problem starting the server

        void socketServer_NewSessionConnected(WebSocketSession session) {
            Console.WriteLine("New client connected from {0}", session.RemoteEndPoint.Address.ToString());

        void socketServer_NewMessageReceived(WebSocketSession session, string value) {
            Console.WriteLine("Client sent {0}", value);
When I run my console app and call the start() method, the program breaks at socketServer.Setup(8711) and displays a prompt a visual studio prompt asking me for the file location of AppServerBase.cs. (see attached screen shot).


If I cancel, the program throws an exception saying:

"Could not load file or assembly 'SuperSocket.SocketEngine' or one of its dependencies. The system cannot find the file specified."

I am already referencing SuperSocket.SocketEngine.dll in my project though, so it must be something that DLL wants that doesn't exist in the source I downloaded.

Jan 28, 2015 at 9:34 AM
I have the same problem. You figured it out yet?
kind regards,

Oct 29, 2015 at 8:30 AM
Change the target framework to 4.5. It worked for me