Unknown Command

Feb 13, 2011 at 7:20 PM

I keep on getting an unknown command message every time I try to send a message. I'm not sure why.

Tried using the console and after installing and running as a service.


* Connecting to server ..
* Connection open
# Unknown command:

I am using Chrome/Windows 7

Sorry I'm very new to this socket stuff.

Feb 14, 2011 at 1:20 AM

Did you set command handler or a sub protocol?

Feb 14, 2011 at 9:10 PM

I'm not sure 100% where to set this, but I have the following

// create a new websocket and connect
ws = new WebSocket('ws://<%= WebSocketPort %>/sample');

Feb 15, 2011 at 1:28 AM

There are two ways to handler websocket request:

1) CommandHandler: the website SuperWebSocketWeb use SuperWebSocket in this way

2) SubProtocol: the project SuperWebSocketTest works in this way. You can follow the code here:



Anyway, I'll provide more documentation for SuperWebSocket. If you still are not very clear about the usage of it, please feel free to ask from me.


Jun 10, 2011 at 4:54 PM

Im getting the same error :) 

* Connecting to server ..
* Connection open
* Secure Connection open
# Unknown command: 


Not sure how to make it "chat" 

Jun 12, 2011 at 3:31 PM

Please check log file to verify your server is started firstly!