New to super websocket

Dec 27, 2011 at 6:46 PM

I downloaded the code for super web socket and got the web project to work in visual studio 2010.  However, when I created a new web project and imported all of the code and references from the downloaded web project, I always got this message:

Chat Message
* Connecting to server ..
* Connection closed
* Secure Connection closed

I even installed the localhost.pfx and supersocket.pfx files.  But I still got the message above.  Not sure what the difference is.  Any help?

Thanks,

Coordinator
Dec 28, 2011 at 12:08 AM
Did you check the log files? They are located in WorkingDir/Logs by default.

From: bachdang
Sent: Wednesday, December 28, 2011 3:46 AM
To: [email removed]
Subject: New to super websocket [SuperWebSocket:284272]

From: bachdang

I downloaded the code for super web socket and got the web project to work in visual studio 2010. However, when I created a new web project and imported all of the code and references from the downloaded web project, I always got this message:

Chat Message
* Connecting to server ..
* Connection closed
* Secure Connection closed

I even installed the localhost.pfx and supersocket.pfx files. But I still got the message above. Not sure what the difference is. Any help?

Thanks,

Dec 28, 2011 at 1:50 PM

I finally got it to work for my own web project.  I had to change the server port in the web.config to something else.  After that, I published it to the IIS.  When I ran it, I noticed that the server connecting message did not show up and when I sent some text, it said "Your browser cannot support websocket".  So more work to do.

Coordinator
Dec 29, 2011 at 12:48 AM

Which browser are you using?

Dec 29, 2011 at 1:22 AM

I use Chrome; works just fine for VS 2010.  Problem is with IIS.  Anything to do with the following:

ws = new window[support]('ws://<%= Request.Url.Host %>:<%= WebSocketPort %>');

How about websocket port?  How do I set the port to something other than port 80?  

I hate to give up this up just for a minor issue.

Coordinator
Dec 29, 2011 at 1:24 AM

Please check the log files to see whether the server is started correctly.

They are located in WorkingDir/Logs by default.