SuperWebSocket SSL/WSS problem

May 22, 2013 at 1:48 PM
Hi,
I have strange problem with websocket server config.

When i use code like this (withs tls security) :
  websocket.Setup(rootConfig, new ServerConfig
            {
                Name = "SecureSuperWebSocket",
                Ip = "Any",
                Port = 9999,,
                Mode = SocketMode.Tcp,
                Security = "tls",
                Certificate = new SuperSocket.SocketBase.Config.CertificateConfig
                {
                    FilePath = "@localhost.pfx",
                    Password = "supersocket"
                }
                
            });
and try to compile code, I have websocket.Start() error:
You cannot start a server instance which has not been setup yet.
But when i use setup parameters without tsl like that:
  websocket.Setup(rootConfig, new ServerConfig
            {
                Name = "SecureSuperWebSocket",
                Ip = "Any",
                Port = 9999,
                Mode = SocketMode.Tcp,
              
            });
Everything is fine. I tried many options and i can't get it, why tsl doesn't want to work.

Really, i will be so glad for any suggestions.
Coordinator
May 22, 2013 at 2:50 PM
Did you check the error log?

If you cannot find it, please read this document:
http://docs.supersocket.net/v1-5/Logging-in-SuperSocket

BTW, if you want to use "localhost.pfx", please install it into your trust certificate store.

AND "@localhost.pfx" => "localhost.pfx"