Super Web Socket basic Console Not connecting with a mobile device

Feb 21, 2014 at 5:42 AM
Hi Kerry,

Thanks to your samples I was able to implement the Basic Web Socket console and the Test html file is also working fine with localhost as well as my ip address.

but when I try to connect it through my mobile device application

stating ws://my_ip_address:2012/
connection is getting lost

Can you tell me where and what M I doing wrong?

Thanks,
Feb 21, 2014 at 7:51 AM
Do I need to have a static ip or some thing like that?
Feb 21, 2014 at 9:22 AM
Does your client using a sub protocol to connect server?
Feb 21, 2014 at 9:24 AM
No, I just explored the Sample A ie Basic Console...
Feb 21, 2014 at 9:32 AM
check if your Firewall blocked your port(2012).(use telnet to test.)
Feb 21, 2014 at 9:35 AM
The Test.Html is working fine on my browser its connecting to the server sending and receiving messages and disconnecting as well.

This problem is with my mobile device.

Telnet for websockets?

can you show me the sample code if aqny?
Feb 21, 2014 at 10:06 AM
Edited Feb 21, 2014 at 10:08 AM
If your mobile client has sent a header 'Sec-WebSocket-Protocol' to server, then you need to setup a sub-protocol to your server, or your server will disconnect the connection directly.
Feb 21, 2014 at 10:10 AM
Ok Thanks, Let me go for sub protocols then,
and I will get back to you if I struck some where.

You guys are great....
Feb 21, 2014 at 10:33 AM
Hi,

I issue is still there I made my websocket into sub programs

As per the sample B in the websocket.

Still I'm able to access it in my browser but not through my mobile...

Any suggestions.
Feb 24, 2014 at 4:10 AM
Hi ccfish,

As you mentioned earlier to set up sub-protocol to my server, I did the same but my connection is still getting disconnected.

Any suggestions?

Thanks,
Mar 5, 2014 at 9:58 AM
Hi,

Can anybody suggest me a way to connect the web socket to external devices???