SubCommandBase Problems and Log missing

Apr 16, 2014 at 3:25 PM
I am trying to set up a websocket on Azure. I have followed the Cloud example and the Worker role is running and the Test.html connects to it. The problem I am having is executing commands. I have the echo command on the same directory as my WorkerRole.cs. Nothing happens when I send an echo command from Test.html. Also I cannot find my Log files. I have tried using LogUtil.setup() but the LogUtil does not exist on the current context. My code is identical to the Cloud Example. Please help. Thank you!
Coordinator
Apr 16, 2014 at 3:46 PM
The "LogUtil.setup()" is out of date.

You just need to make sure the log4net.config is deployed to the "Config" folder of your WorkRole.
Apr 16, 2014 at 3:53 PM
Edited Apr 16, 2014 at 5:18 PM
Thank you for the fast reply. It is in there exactly as it is in the cloud example, but I cant seem to be able to locate the logs. What path are they usually in?
Coordinator
Apr 19, 2014 at 12:04 PM
Did you try to login the instance through remote desktop?
Apr 21, 2014 at 2:17 PM
Yes, but can not find the logs. I got the subcommand to work by adding the assembly in my config file even though the Echo.cs was on the same Assembly as WorkerRole.cs .
Coordinator
Apr 21, 2014 at 3:20 PM
Do you have the log4net.config file in the Config directory?
Apr 21, 2014 at 3:22 PM
Yes. Just like the cloud example.
Coordinator
Apr 21, 2014 at 3:28 PM
Did you check the config file also exist in the running instance's working directory instead of only check it in your source code file directory?
Apr 21, 2014 at 3:39 PM
On approot? It is not there.
Coordinator
Apr 21, 2014 at 4:15 PM
Of source your running directory. Set the configuration file's build action to "copy as local"
Apr 22, 2014 at 1:42 PM
I do not have that option on Visual Studio 2013.
Coordinator
Apr 22, 2014 at 2:30 PM
Don't you have it?

Image
Apr 22, 2014 at 2:44 PM
Thank You very much. Everything is working great now.